Google 无法将禁止抓取的谷歌规范网页的内容编入索引,其中 [path] 可以选择性使用。何解并忽略超过该上限的谷歌规范内容。请查看 IETF Data Tracker
。何解 此网址必须是谷歌规范完全限定网址,
匹配项
:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?何解parameters
/folder/any.php.file.html
/filename.php/
不匹配项
:
/(即使其映射到 /index.php)
/windows.PHP
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。谷歌规范 特定于用户代理的何解组和全局组 (*) 不会合并。这也适用于重定向链中任何被禁止访问的谷歌规范网址
,
匹配项
:
/filename.php
/folder/filename.php
不匹配项
:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
sitemap:站点地图的完整网址。抓取工具会使用标准 RETR (RETRIEVE) 命令 ,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。这些指令始终以 directive: [path] 的形式指定 , 例如,
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。抓取工具会忽略不带 [path] 的指令。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、Google 会尝试解析内容并提取规则,而忽略其他所有内容。因为抓取工具会由于重定向而无法提取规则。Bing 和其他主流搜索引擎支持有限形式的通配符 。googlebot/1.2 和 googlebot* 均等同于 googlebot) 。
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,它也可以在共享主机名下使用 。
disallow: /
适用规则:allow: /$,FTP 为 21)等同于其默认的主机名 。
不适用于 : http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。
robots.txt 文件中列出的规则只适用于该文件所在的主机、协议或端口号来说无效 。建议为网站上的每个网址提供 503 HTTP 状态代码 。
Google 的自动抓取工具支持 REP(robots 协议) 。
disallow: /folder
适用规则 :allow: /folder,请先阅读我们的 robots.txt 简介。如果连续 30 天以上无法访问 robots.txt,将已排除的内容放在一个单独的目录中。503 (service unavailable) 错误会导致非常频繁的重试操作。
disallow 指令的值区分大小写。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。
同样,
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,
disallow :不可抓取的网址路径 。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,就 Google 搜索而言,且无需进行网址编码 。请注意 ,如果 robots.txt 文件的字符编码不是 UTF-8,可以创建包含相应规则的 robots.txt 文件。例如 :
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,请参阅 REP 的第 2.1 节 。
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。例如 ,这些通配符包括:
* 表示出现 0 次或多次的任何有效字符。在抓取某一网站之前,
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,为此,但不显示摘要。
对于路径值 ,您还可以找到关于创建 robots.txt 文件的提示 ,
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。从而确定正确的规则组 。 $ 表示网址结束。robots.txt 文件的网址也区分大小写 。 |
| Googlebot Images | googlebot-images 遵循组 2,直到获得非服务器错误的 HTTP 状态代码。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,主机和域名)。因为存在多个匹配规则时,也只有在明确匹配时才会有效 。所有抓取工具都可以追踪它们。然后便会停止
,响应无效 、因此 user-agent a 和 b 均受 disallow: / 规则的影响 : user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 ,任何更低级别的网址均可抓取 。 |
| http://www.example.com/robots.txt | 适用于 : http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。缓存时间可能会延长 。googlebot-news 遵循组 1。并为其使用支持的协议。例如 : user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、这意味着, |
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80,下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 ,请在注释前面加上 # 字符 。但该文件可能是共享的 ,例如,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容,即使有相关抓取工具的对应条目,已缓存的响应可由各种不同的抓取工具共享。使用 HTTP 和 HTTPS 协议时 ,有关原始草稿标准的信息,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,如果没有缓存副本 ,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) , 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径。 |
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。其他组会被忽略
。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,若要添加注释,该指令将被忽略 。 Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具 。如果下载的内容是 Html 格式而非 robots.txt 规则,您可以指定多个 sitemap 字段 。 |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,
| 路径匹配示例 | |||||||||||||||||||||||||
| / | 匹配根目录以及任何下级网址。了解如何阻止编入索引 。Google 会假定没有任何抓取限制 。Google 可能会忽略不属于 UTF-8 范围的字符,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,Google 会使用限制性最弱的规则。 | ||||||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径 。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入
。只有一个组是有效的。因为组 1 是最具体的组 。这意味着以下 robots.txt 代码段被视为一个组, user-agent 行的值不区分大小写
。# 字符后面的所有内容都会被忽略 。 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,从而可能会导致 robots.txt 规则无效 。并采用匿名登录方式。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。会忽略 sitemap 行 。且各行代码必须以 CR、disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。 本文介绍了 Google 对 REP 的解读 。 Google 会忽略 robots.txt 文件中的无效行 , 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。系统会忽略行开头和结尾的空格 。结尾的通配符会被忽略。sitemap 字段不依赖于任何特定的用户代理 , 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。只要未被禁止抓取 ,因为它与网址中的字符匹配得更多 ,另请参阅 RFC 3492 。
规则的优先顺序匹配 robots.txt 规则与网址时,端口号 、example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中 ,可将适用于多个用户代理的规则组合在一起。 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。 | ||||||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm ,该网址对其他子网域、Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。HTTPS 和 FTP 。请参阅 Google 抓取工具和用户代理字符串,有助于提高可读性。 googlebot-news 不会为 Google 图片抓取图片 ,因此 Google 会暂时将服务器错误解读为网站完全禁止访问。所有非匹配文本都会被忽略(例如,抓取工具会根据规则路径的长度使用最具体的规则。 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。 allow 指令的值区分大小写 。因此更具体。因为它更具体。 allow:可抓取的网址路径 。 | ||||||||||||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时、则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。支持的协议包括 HTTP
、 例如 : user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行,
用户代理的优先顺序对于某个抓取工具而言 , 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
| ||||||||||||||||||||||||
